1.2 Preview crashes after opening and closing new script file

Split from: Can't enter special characters via Unicode character code in Ubuntu (ctrl+shift+u)

That fixed it. Thanks!

EDIT: Had to uninstall it because it's crashing every time I load libraries. No time to diagnose that right now.

Can you provide us with a GDB stack trace? You should be able to generate one with the following steps.

First, close any running instances of RStudio, and then launch a new lone RStudio instance.

Then, in a terminal, start GDB and have it attach to RStudio. You should be able to do this with:

sudo gdb -p `pidof rsession`

If you do not have the pidof utility installed, you can run Sys.getpid() in your R session to get the session's process ID.

After this, GDB should (hopefully) successfully attach to the process. Next, we'll instruct GDB to log to a file:

set logging file rstudio.log
set logging on

Finally, we'll tell GDB to let RStudio continue running:


Now, return to your RStudio session and try running the code that triggered the crash. With luck, if RStudio crashes, GDB should catch the fault. Return to GDB, and enter:


You should now be able to quit GDB with


and then make the file at 'rstudio.log' available to us for further inspection.

Sorry for the delay. I downloaded the preview release again today and gave it a try.

It used to crash consistently shortly after loading my libraries and running a couple of commands, but now I was able to run everything smoothly. However, once I click on the 'x' to close the tab with the script I just run, it instantly closes. Here's the log:


Thread 3 "rsession" received signal SIGABRT, Aborted.
[Switching to Thread 0x7f131f1c9700 (LWP 2295)]
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
51	../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x00007f1323737801 in __GI_abort () at abort.c:79
#2  0x00005635ffe8a969 in rstudio::core::system::abort() ()
#3  0x00005635ff9e10e4 in (anonymous namespace)::detectParentTermination() ()
#4  0x00005635ffd76220 in rstudio_boost::detail::thread_data<rstudio_boost::function<void ()> >::run() ()
#5  0x00005635fffbcf55 in thread_proxy ()
#6  0x00007f13253086db in start_thread (arg=0x7f131f1c9700)
    at pthread_create.c:463
#7  0x00007f132381888f in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
Detaching from program: /usr/lib/rstudio/bin/rsession, process 2293

Additionally, my entire OS froze up a couple of times and I had to force reboot but I wasn't able to pin down the behavior that caused this.

EDIT: I tried reopening RStudio and everything froze again. I believe an rsession process was still active even after RStudio crashed, maybe that caused some conflict? After restarting now, I can confirm that simply creating a new code tab and closing it causes RStudio to crash, and all subsequent attempts result in it closing briefly after the window appears.

Can you try running the same steps, this time debugging the rstudio executable instead of rsession? I think the crash is occurring within the RStudio front-end rather than the rsession itself.

RStudio behavior remains as reported previously. There seem to be problems when trying to attach to rstudio and after continue I find it has frozen even before having interacted with it.

Pre logging messages:

Attaching to process 27654
[New LWP 27657]
[New LWP 27658]
[New LWP 27659]
[New LWP 27660]
[New LWP 27662]
[New LWP 27698]
[New LWP 27700]
[New LWP 27701]
[New LWP 27702]
[New LWP 27703]
[New LWP 27704]
[New LWP 27705]
[New LWP 27706]
[New LWP 27707]
[New LWP 27708]
[New LWP 27709]
[New LWP 27710]
[New LWP 27711]
[New LWP 27712]
[New LWP 27713]
[New LWP 27714]
[New LWP 27715]
[New LWP 27716]
[New LWP 27717]
[New LWP 27718]
[New LWP 27719]
[New LWP 27727]
[New LWP 27730]
[New LWP 27747]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
/build/gdb-GT4MLW/gdb-8.1/gdb/symfile.c:944: internal-error: sect_index_text not initialized
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) n

This is a bug, please report it.  For instructions, see:

/build/gdb-GT4MLW/gdb-8.1/gdb/symfile.c:944: internal-error: sect_index_text not initialized
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) y
Command aborted.
(gdb) 0x00007f7e01febbf9 in __GI___poll (fds=0x563d55029890, nfds=6, timeout=50)
    at ../sysdeps/unix/sysv/linux/poll.c:29
29	../sysdeps/unix/sysv/linux/poll.c: No such file or directory.

(gdb) set logging file rstudio_2.log
(gdb) set logging on
Copying output to rstudio_2.log.

Log output:


Thread 15 "TaskSchedulerSi" received signal SIGSTOP, Stopped (signal).
[Switching to Thread 0x7f7dc5ffb700 (LWP 27707)]
0x00007f7e03aee9f3 in futex_wait_cancelable (private=<optimized out>, 
    expected=0, futex_word=0x7f7dc5ffacb8)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:88
88	../sysdeps/unix/sysv/linux/futex-internal.h: No such file or directory.
#0  0x00007f7e03aee9f3 in futex_wait_cancelable (private=<optimized out>, 
    expected=0, futex_word=0x7f7dc5ffacb8)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x7f7dc5ffac68, 
    cond=0x7f7dc5ffac90) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x7f7dc5ffac90, mutex=0x7f7dc5ffac68)
    at pthread_cond_wait.c:655
Backtrace stopped: Cannot access memory at address 0x7f7dc5ffac08
Detaching from program: /usr/lib/rstudio/bin/rstudio, process 27654

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.