413 request error while using Shinyapps.io, how to modify nginx config?

I need to upload a large (~600MB) file to my shiny application, which is deployed on shinyapps.io. It throws an error:

<html>
 <head><title>413 Request Entity Too Large</title></head>
 <body bgcolor="white">
 <center><h1>413 Request Entity Too Large</h1></center>
 <hr><center>nginx</center>
 </body>

This has been discussed before (e.g., https://stackoverflow.com/questions/49666900/413-request-error-while-using-shiny), where the suggested solution is to add
options(shiny.maxRequestSize = 9000*1024^2)
to the code. But this doesn't solve the issue. It's the nginx that is causing the issue, and according to a comment on the SO, client_max_body_size needs to also be changed. How can I do this on my app?
I have attached a screenshot of my app just in case.

The maximum body size to applications running on shinyapps.io is 512M, which is distinct from the upload size of bundles.

Try compressing your file, or splitting into multiple uploads.

@josh Thank you. Just to clarify: Let's say I compress the file to less than 500M. I would still need to uncompress it after it's been uploaded (the input is a .csv table, so uncompress -> read.csv()). Does this 512 MB limitation mean that even then (i.e., after uncompressing) it will throw an error? or is it just a limitation during the upload process?
And if I may ask another question, does moving to the "Starter" option remove this limitation?
Thanks again!

No, the limitation is on uploads to the application, which is the same for all plans.
Mind you, when the application resumes after sleeping it will no longer have the file.
You can include the file as part of the application that is deployed, in which case there are different limitations based on the plan.

Thank you, this solved my problem!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.