502 Error Bad Gateway


#1

Hi Everyone,

I have an app that takes about 5 mins or so to start up so I added an app_init_timeout parameter in my shiny-server.conf file yet it doesn’t work for some reason. This is what my shiny-server.conf file looks like:

Instruct Shiny Server to run applications as the user “shiny”

run_as shiny;

Define a server that listens on port 3838

server {
listen 3838;

Define a location at the base URL

location / {

# Host the directory of Shiny Apps stored in this directory
site_dir /srv/shiny-server;

# Log all Shiny output to files in this directory
log_dir /var/log/shiny-server;

# When a user visits the base URL rather than a particular application,
# an index of the applications available in this directory will be shown.
directory_index on;

app_init_timeout 1600;
}

}

I also tried putting the app_init_timeout parameter at the top, outside the location, basically every possible place; still doesn’t seem to work.
Somebody help!

Thanks,
Abdur