Adjusting scrolling amount for Slimblade trackball in RStudio


#1

Hi all,

I'm using RStudio V1.1.453 on Windows 8.1 Enterprise with a Kensington Slimblade trackball (using TrackballWorks 1.3.1).

The trackball can be used as a scroll wheel by rotating the trackball so that current window (console, terminal or source code) can be scrolled up and down. However, the problem is that the window scrolls almost a whole page, which makes moving to the appropriate section of code difficult.

The scrolling features works fine for all other programs such as Firefox, Libreoffice and MS Office, where the screen only scrolls a small amount, not almost a whole page.

I've searched RStudio settings and cannot see anything that can adjust this behaviour. Likewise, I've checked both the TrackballWorks settings and the windows mouse settings, but cannot see where I can change this behaviour.

Is there an option to change the amount moved by the scroll wheel in RStudio? Or is this a bug, given RStudio is the only application that has this problem?

Thanks


#2

Do you see the same scrolling behavior in the Ace editor instance here? https://ace.c9.io/build/kitchen-sink.html


#3

Thanks @kevinushey no it does not have the same problem. It only scrolls about 9 lines at a time (which does seem too many for me)


#4

Any other options or debugging I can try on my end?


#5

Unfortunately, I'm not aware of anything RStudio-specific that can be done to work around this issue.

Just for our information, does it make a difference if you adjust some of the scroll-related settings within Windows directly? E.g. in Settings -> Mouse:

I realize these are a global settings and so you likely don't want to change them just for RStudio, but this might help us learn a bit more about what's going on.


#6

Hi @kevinushey,

Sorry late reply. I just checked the settings in Windows as per your suggestion, but the mouse setting is already set to 1 line to scroll.

I just plugged in a standard mouse with scroll wheel and it does not have the same problem as the Kensington Slimblade, So it looks like a Kensington driver problem then...


#7

The last thing I might suggest -- we've done some pretty heavy infrastructure updates coming to the next version of RStudio. We have daily builds of this version of RStudio available here:

https://dailies.rstudio.com

Any chance the situation is improved there?