Agricolae package

I have tried to install Agricolae package and after several attempts, I succeed but it seems there is something wrong. When I call the package, I get the following message:


Error: package or namespace load failed for ‘agricolae’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):

there is no package called ‘sf’
How I fix this problem please. Thanks

You need to install that dependency


I tried that too, but there is something wrong.

What is wrong when you install sf ?

1 Like

I will try to delete the package, then I will re-install it.

I am not sure, but wrong message appeared. Any way, I will delete my packge then I will re-install it. Thanks.

Could you post the whole error message?

I am sorry bro but may I ask you: Is there a possibility to save a file .xsIx or .csv into .rda file format?.

Thanks, andresrcs, but now I deleted the package and I will re-install it first. I will let you know the result.

After re-installing the package (agricolae), I call the package and the result as following:


Error: package or namespace load failed for ‘agricolae’ in get(Info[i, 1], envir = env):

cannot open file 'C:/Users/x9-999/Documents/R/win-library/3.5/Matrix/R/Matrix.rdb': No such file or directory


Please notice the directory of agricolae; is: C:\Users\x9-999\Documents\R\win-library\3.5\agricolae.

It seems like you are having problems with your Matrix package, try uninstalling and reinstalling.

If you have recently updated to R >= 3.5 from R < 3.5 you are going to have a lot of this problems, if that is your case, I suggest you to reinstall all your packages.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.