Arrows to navigate columns not working RStudio

I am working with a big dataset of over 500 variables (columns) and have been having some trouble navigating between the columns. The arrows (<< < > >>) that one uses to go back and forth between the columns randomly stopped working for me in my RStudio around 8-10 hours ago and haven't worked since. Things I have tried:

  • Reinstalling RStudio
  • Restarting my computer
  • Updating MacOS to the latest
  • Updating packages on R
  • Leaving it alone for a few hours

Any help would be appreciated. For reference I use an M2 Macbook Air with MacOS Ventura 13.4 on it.

This seems to be the same issue reported here.

I am also have this issue with them most recent version of RStudio 2023.06.0+421

I am joining this thread because I am having the same issue. The arrows were working fine until I downloaded RStudio 2023.06.0+421. I am working on a MacBook Pro using OS Monterey 12.6 and R 4.2.0. Like @jahnavi I closed everything and restarted RStudio, reinstalled RStudio, and ensured everything was updated.
If it's helpful for anyone on this post, the link shared above has this workaround:
rstudioapi::writeRStudioPreference("data_viewer_max_columns", 1000L)
A word of caution around it: Make sure that the value is no larger than the number of columns. If you do, then the >> will become clickable, and clicking on it could cause the application to freeze.
Hopefully this issue gets fixed, it's incredibly annoying.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.