Attaching to rserver from outside

rserve

#1

I'm attempting to connect Tableau to the rserver that is part of RStudio, but it appears to be bound to localhost. Note: I'm not trying to connect to RStudio-server, I'm trying to connect to rserver.

It's running on port 6311 just fine, and I can telnet onto it from the server that it's running on, but can't telnet onto it from anywhere else. I tried disabling the firewall to no avail.

This is on Centos 7 running the latest RStudio release.


#2

Hi @Mythobeast! Welcome!

Can you clarify your setup a bit? Are you using Rserve?

RStudio (the product) is an IDE for R (the language/environment) — see: Differentiating R from RStudio


#3

Yes. One of our data scientists installed RServe via the RStudio command line, and started it up from there. Do let me know if there's a better approach. I can't find the configuration files for changing the bind-to address.


#4

Actually, now that I know it's a separate product, I see that I'm supposed to include 'remote enable' in the config file. Now if i can just find the config file.


#5

Yeah, I suspect your colleague installed and started Rserve via the command line interface to R, not the RStudio IDE (though RStudio does include terminal access as a convenience, so the distinction can get muddy...). Either way, you are correct that Rserve doesn't really have anything to do with the RStudio IDE. R people's passion for including "r" in the name of everything can get confusing! :grin:


#6

Hi Mythobeast,

Are you resolved tableau server to Rserve connectivity issue ? if you found any solution please share me ..

I have installed the RServe package and trying to connect the RServer from Tableau desktop .Tableau server ,tableau desktop are in different machine so I need to redirect the 127.0.0.1 local to R Server IP address so that I can update the below setup

6311 port is binned with local host address ,how to redirect this local ip to server id address ?

I updated only following two properties to work it-
vizqlserver.extsvc.host – server ip address instead of local host
vizqlserver.extsvc.port - 6311

  • DONE (Rserve)
    Making 'packages.html' ... done

library(Rserve);
Rserve()
Starting Rserve:
/usr/lib64/R/bin/R CMD /usr/lib64/R/library/Rserve/libs//Rserve

[root@Servername etc]# netstat -an |grep 6311
tcp 0 0 127.0.0.1:6311 0.0.0.0:* LISTEN

Thanks
Surendar