Auto Stop RStudio Server

rstudio

#1

Hi All,

I have RStudio Server running on CentOS 7. Currently, the RStudio Server starts on its own whenever the machine boots up. I don’t want this to occur unless I specifically run rstudio-server start command after booting.

Is there a way to disable it permanently?

Thanks.


#2

Yes, you can do this, but the details are somewhat specific to your system configuration. If you’re using systemd, try something like this:

$ systemctl disable rstudio-server

#3

Hi @jonathan,

Doesn’t seem to work on CentOS 7:

~$ sudo systemctl disable rstudio-server
~$ sudo systemctl status rstudio-server
● rstudio-server.service - RStudio Server
   Loaded: loaded (/etc/systemd/system/rstudio-server.service; disabled; vendor preset: disabled)
   Active: active (running) since Mon 2017-10-30 17:33:50 MST; 12s ago
 Main PID: 27864 (rserver)
   CGroup: /system.slice/rstudio-server.service
           └─27864 /usr/lib/rstudio-server/bin/rserver

Oct 30 17:33:50 localhost.localdomain systemd[1]: Starting RStudio Server...
Oct 30 17:33:50 localhost.localdomain systemd[1]: Started RStudio Server.
Hint: Some lines were ellipsized, use -l to show in full.

Any other suggestions?

Thanks.


#4

“disable” doesn’t stop the service; it just keeps it from starting automatically. Did it do that?

If not, you might try editing the file /etc/systemd/system/rstudio-server.service directly (refer to the systemd service file documentation for how to do this).