Background color of plot pane

Hi,

I used RStudio with a dark background color and the Modern RStudio theme.
Everything was perfect, meaning all panes (and buttons etc) were dark except for the plot pane, which had a white background color (which I liked, because I can see the plot correctly).

Yesterday, I ran a bunch of updates on my machine (including RStudio) and all of a sudden, the background color of the plot pane is dark as well. That means, the plots are almost unreadable.

I know that I can manually draw a frame around each plot and fill it white, but that's super inconvenient to do for every plot! I also know that I can use the Classic RStudio theme, but then all buttons etc are white/gray, which I also don't like.

Is there a way of going back to the appearance as it was?
Below is a screenshot.

Thanks for any help!
Best wishes,
Flo

Hi, welcome!

On what operating system are you? What is your version of RStudio?

FWIW, 1.2.1335 versions, both desktop and server, work as expected on windows 10, ubuntu 18 and debian9.
image

Hi,

oh that's weird.
I'm on Linux Mint 19.1, which is basically ubuntu 18.
My RStudio Desktop is on 1.2.1335 as well.

Do you have an idea what else might be causing this behavior?

I get a white background if i click on 'Zoom'.

Thanks for your thoughts!

Not really, but I can think on a couple more things to try

  • Change theme apply and change back.
    image
  • Reset RStudio`s State

Just to confirm -- do you see this with all plots, even e.g. plot(1)?

Thanks a lot for your guys' help and thoughts!

Just to confirm -- do you see this with all plots, even e.g. plot(1) ?

Actually, it ended up being an update in our internal plotting routine where the background color was changed to 'transparent'.
Sorry for not having thought about that possibility earlier!