Blurry resolution with High DPI Surface Pro with R studio

Hi folks,

So I just switched over from a mac to a Surface Pro 2, and I'm struggling here a bit to get the screen to not blur...

I know there is a pre-existing question that is similar, however, I have tried the recommendations and they do not seem to solve the problem see here

Stackoverflow response here

I have tried changing the global settings, between, "auto-detect", "Desktop Open GL" and, "Software" as well as

At this point I'm at a bit of a loss... Even if the text is manageable, the plot window and zoom are unusable at the moment.

Is there a fix for this I haven't tried? To note, I haven't had a Windows computer in awhile, so i'll likely struggle with any terminal solutions


What RStudio version are you using?, as long as it is 1.2 or higher it should work with "Program DPI" on the DPI settings (without "High DPI scaling override"). This configuration works for me, on a Surface Pro as well.

I'm running: RStudio-1.3.1093

Hmmm... I made that change and it's still producing the plot area strangely

Although the text is marginally better.

I wonder if now it's just fixing the Zoom settings, but I don't think that's the issue with plot rendering

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.