Bookdown's gitbook appendix header not working

My # (APPENDIX) Appendix {-} which was being treated previously as an unnumbered header:

24%20AM

is no longer being treated as such:

27%20AM

I am using the same (newest) version of bookdown. I'm wondering if something changed in gitbook?

Another change from before is that I specified split_by: chapter+number in _output.yml so previously my output files were:

1-main.html
A-supplemental.html

and now they are:

main.html
appendix-appendix.html
supplemental.html

The appendix-appendix.html is definitely erroneous as it should be an unnumbered header. Is anyone else noticing similar behaviour?

Can you work a reproductible example to investigate that ?
For example by forking and branching from bookdown-demo and sharing your branch in your fork ?

This would really help trying to reproduce. There may be some side effect of recent changes.

I don't have the capacity right now to create a reprex repo, but the issue arises from the recent pandoc update 2.7.3 -> 2.8. Seems like some related issues have already been raised:


For anyone trying to revert back on macOS, I ran the following via https://stackoverflow.com/a/46306176:

cd "$(brew --repo homebrew/core)"
git log master -- Formula/pandoc.rb
cd "$(brew --repo homebrew/core)" && git checkout b65f084e360a327aa25acf24d25fcabc3e9aa19c
brew unlink pandoc
HOMEBREW_NO_AUTO_UPDATE=1 brew install pandoc
git checkout master

Afterwards my bookdown report no longer had heading/numbering issues. Perhaps time to flag bookdown developers?

1 Like

Yes you can open issue in bookdown repo with an example and your test. Just check if already raised or not.
Pandoc 2.8 can cause some pain for sure.

For reference, it has been reported to