Can not find "rstudio-connect.gcfg" file under /etc/rstudio-connect/

I am trying to follow up this instruction on the following link Installing packages on RStudio Connect from behind a proxy – RStudio Support
to configure the setting of downloading the R-packages through a proxy server. However, I can not find "rstudio-connect.gcfg" from /etc/rstudio-connect/, actually there is no "rstudio-connect" directory under /etc/. I tried "find . -name rstudio-connect" in the root directory, seems like no such directory on our RedHat enterprise 7 system. Any help would be appreciated!

How did you install RStudio Connect on that server? Did you follow our installation instructions at Install RStudio Connect - RStudio Documentation?

I do not think I separately installed rstudio connect when installing Rstudio our system before. Our system is internet disabled due to the security issue. I will give it a try. Thanks.

It's worth noting that RStudio and RStudio Connect are two very different things :grinning_face_with_smiling_eyes: RStudio usually refers to the IDE server edition (Community Edition or RStudio Workbench - previously RStudio Server Pro). RStudio Connect is a publishing platform for hosting data science assets like Plumber APIs, Shiny Apps, Flask APIs, etc.

I just want to be sure that is clear, in case there is some confusion there!

Then could you please let me know how to install R packages on R or Rstudio through a proxy server? Any help would be appreciated! Thanks in advance.

Quoting from ?download.file

Setting Proxies
For the Windows-only method "wininet", the ‘Internet Options’ of the system are used to choose proxies and so on; these are set in the Control Panel and are those used for system browsers.

For the "libcurl" and "curl" methods, proxies can be set via the environment variables http_proxy or ftp_proxy. See libcurl - programming tutorial for further details.

In current(!) versions of RStudio Server/Workbench you can set those environment variables via 2 Server Management | RStudio Workbench 1.4.1717-3.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.