Can not install packages (something wrong with ggthemes)

I have a problem with installing packages
it seams something wrong with "ggthemes" but I couldn't find any solution for this.
(I've tried a lot to re-install "ggthemes" and packages)

Here is a commend and error message

Thank you for your help in advance

> install.packages("Rcpp")

  There is a binary version available but the source version is later:
     binary source needs_compilation
Rcpp  1.0.6  1.0.7              TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel) yes
installing the source package ‘Rcpp’

trying URL ''
Content type 'application/x-gzip' length 2941808 bytes (2.8 MB)
downloaded 2.8 MB

Error: Can't subset columns that don't exist.
x Column `ltgray` doesn't exist.
  1. ├─ggplot2::theme_set(theme_gogamza())
  2. └─global::theme_gogamza()
  3.   ├─ggplot2::theme(...)
  4.   │ └─ggplot2:::find_args(..., complete = NULL, validate = NULL)
  5.   │   └─base::mget(args, envir = env)
  6.   ├─ggplot2::element_rect(...)
  7.   │ └─base::structure(...)
  8.   ├─ggthemes_data$fivethirtyeight["ltgray"]
  9.   └─tibble:::`[.tbl_df`(ggthemes_data$fivethirtyeight, "ltgray")
 10.     └─tibble:::vectbl_as_col_location(...)
 11.       ├─tibble:::subclass_col_index_errors(...)
 12.       │ └─base::withCallingHandlers(...)
 13.       └─vctrs::vec_as_location(j, n, names)
 14.         └─(function () ...
 15.           └─vctrs:::stop_subscript_oob(...)
 16.             └─vctrs:::stop_subscript(...)
Execution halted
Warning in install.packages :
  installation of package ‘Rcpp’ had non-zero exit status

The downloaded source packages are in
# A tibble: 6 x 2
  name        value  
  <chr>       <chr>  
1 Dark Gray   #3C3C3C
2 Medium Gray #D2D2D2
3 Light Gray  #F0F0F0
4 Red         #FF2700
5 Blue        #008FD5
6 Green       #77AB43

Please post the specific command you are using to install and the complete error message you get. (preferably after restarting your R session)

Thank you for your attention! I edited under your advice. Hopefully, it's correct.

The easiest solution is to answers "no" to this question and install the binary version.

I honestly don't know what might be going wrong with Rccp compilation, it seems it fails rendering a vignette or something like that.

Thank you for your help!

Actually, I tried answers "no", but still have a problem.
And the same error keep showing on not only Rcpp but stringi, cli, and isoband etc.
The trouble shooting has occurred after installing Java,
do you think I need to do something with Java?


The error message doesn't suggest that but also, it doesn't make much sense, this is the first time I see that kind of error message appear during installation. Are you sure it is the complete error message and you are not omitting anything? I ask because the error message seems to be taked out of context.

Have you recently added or changed some of the startup files? i. e.,, .Renviron or .Rprofile

First, Happy birthday! andresrcs!

Hmm.. I am pretty sure it's the complete message.
Anyway, I erase all of startup files, cause you mentioned it, and solved the problem!

Thank you so much, Have nice and awesome day!

Thanks, although technically it's not my birthday yet, I'm in another timezone GMT -5

Hahaha I brought a birthday cake from the future :rofl:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.