Cannot deploy my site in Netlify

blogdown

#1

Hi, I'm trying to deploy my site in Netlify. But the error message shows that I have error running command: build script returned non-zero exit code: 255.

I copied my log in below.

3:12:03 AM: Build ready to start
3:12:05 AM: Fetching cached dependencies
3:12:05 AM: Starting to download cache of 254.7KB
3:12:05 AM: Finished downloading cache in 122.587914ms
3:12:05 AM: Starting to extract cache
3:12:05 AM: Failed to fetch cache, continuing with build
3:12:05 AM: Starting to prepare the repo for build
3:12:07 AM: No cached dependencies found. Cloning fresh repo
3:12:07 AM: git clone git@github.com:jystatistics/jjyblog
3:12:08 AM: Preparing Git Reference refs/heads/master
3:12:08 AM: Starting build script
3:12:08 AM: Installing dependencies
3:12:09 AM: Downloading and installing node v8.11.3...
3:12:10 AM: Downloading https://nodejs.org/dist/v8.11.3/node-v8.11.3-linux-x64.tar.xz...
3:12:10 AM: 
#                                                                          2.3%
3:12:10 AM: #
3:12:10 AM: #######                                                                  11.3%
3:12:10 AM: #
3:12:10 AM: ##############                                                           21.2%
3:12:10 AM: 
######################
3:12:10 AM:      30.7%
3:12:10 AM: #
3:12:10 AM: ###########################                                              40.1%
3:12:10 AM: 
###################################
3:12:10 AM:    49.8%
3:12:11 AM: 
##########################################
3:12:11 AM:                          59.3%
3:12:11 AM: 
##################################
3:12:11 AM: ###############                         69.4%
3:12:11 AM: 
######################################
3:12:11 AM: ##################                  79.0%
3:12:11 AM: 
##############################################
3:12:11 AM: ##################          89.3%
3:12:11 AM: 
##############################################################
3:12:11 AM: #########   99.7%
######################################################################## 100.0%
3:12:11 AM: Computing checksum with sha256sum
3:12:11 AM: Checksums matched!
3:12:13 AM: Now using node v8.11.3 (npm v5.6.0)
3:12:14 AM: Attempting ruby version 2.3.6, read from environment
3:12:15 AM: Using ruby version 2.3.6
3:12:15 AM: Using PHP version 5.6
3:12:15 AM: Installing Hugo 0.25
3:12:18 AM: Started restoring cached go cache
3:12:18 AM: Finished restoring cached go cache
3:12:18 AM: unset GOOS;
3:12:18 AM: unset GOARCH;
3:12:18 AM: export GOROOT='/opt/buildhome/.gimme/versions/go1.10.linux.amd64';
3:12:18 AM: export PATH="/opt/buildhome/.gimme/versions/go1.10.linux.amd64/bin:${PATH}";
3:12:18 AM: go version >&2;
3:12:18 AM: export GIMME_ENV='/opt/buildhome/.gimme/env/go1.10.linux.amd64.env';
3:12:18 AM: go version go1.10 linux/amd64
3:12:18 AM: Installing missing commands
3:12:18 AM: Verify run directory
3:12:18 AM: Executing user command: hugo
3:12:18 AM: ERROR 2018/06/18 08:12:18 Current theme does not support Hugo version 0.25. Minimum version required is 0.3
3:12:18 AM: ERROR 2018/06/18 08:12:18 Failed to add template "theme/partials/publication_links.html" in path "/opt/build/repo/themes/hugo-academic/layouts/partials/publication_links.html": template: theme/partials/publication_links.html:16: function "fileExists" not defined
3:12:18 AM: ERROR 2018/06/18 08:12:18 Failed to add template "theme/partials/talk_links.html" in path "/opt/build/repo/themes/hugo-academic/layouts/partials/talk_links.html": template: theme/partials/talk_links.html:30: function "errorf" not defined
3:12:18 AM: ERROR 2018/06/18 08:12:18 Failed to add template "theme/shortcodes/video.html" in path "/opt/build/repo/themes/hugo-academic/layouts/shortcodes/video.html": template: theme/shortcodes/video.html:5: function "fileExists" not defined
3:12:18 AM: ERROR 2018/06/18 08:12:18 theme/partials/publication_links.html : template: theme/partials/publication_links.html:16: function "fileExists" not defined
3:12:18 AM: ERROR 2018/06/18 08:12:18 theme/partials/talk_links.html : template: theme/partials/talk_links.html:30: function "errorf" not defined
3:12:18 AM: ERROR 2018/06/18 08:12:18 theme/shortcodes/video.html : template: theme/shortcodes/video.html:5: function "fileExists" not defined
3:12:18 AM: Started building sites ...
3:12:18 AM: ERROR 2018/06/18 08:12:18 Error while rendering "page": template: theme/talk/single.html:5:5: executing "theme/talk/single.html" at <partial "header_imag...>: error calling partial: template: theme/partials/header_image.html:3:17: executing "theme/partials/header_image.html" at <urls>: can't evaluate field Parse in type interface {}
3:12:18 AM: Caching artifacts
3:12:18 AM: Started saving pip cache
3:12:18 AM: Finished saving pip cache
3:12:19 AM: Started saving emacs cask dependencies
3:12:19 AM: Finished saving emacs cask dependencies
3:12:19 AM: Started saving maven dependencies
3:12:19 AM: Finished saving maven dependencies
3:12:19 AM: Started saving boot dependencies
3:12:19 AM: Finished saving boot dependencies
3:12:19 AM: Started saving go dependencies
3:12:19 AM: Finished saving go dependencies
3:12:19 AM: Cached node version v8.11.3
3:12:19 AM: Error running command: Build script returned non-zero exit code: 255
3:12:19 AM: Failing build: Failed to build site
3:12:19 AM: failed during stage 'building site': Build script returned non-zero exit code: 255
3:12:19 AM: Finished processing build request in 14.554480239s

Thank you for your help!


#2

Are you using blogdown package? Can you update Hugo to fix the error? There is a helper function in blogdown that does that, if I remember correctly.


#3

I'm using #blogdown package. I updated Hugo to 0.3, but it is not sill working.


#4

Can it be the other way? Netlify doesn't have correct version of Hugo, so you need to downgrade to 0.25 instead?


#5

Netlify definitely supports above 0.25, but @jystat, is Netlify configured to use 0.30?

This is in the blogdown book,


but I happened to write a post on it as well:


#6

Thank you for your help!
I found out that the minimum hugo academic version is 0.30 today. After I changed to 0.35 in my deploy setting, it works!
Thanks!


#7

Great it works now!
Can you mark your topic as resolved so that everyone sees in the list of topics that it has been answered?
Thanks!


#8

Sure! How can I mark my topic as resolved? @cderv


#9

There is a FAQ on this topic

:wink:


#10

Thank you :slight_smile: