Cannot load the xlsx library (ubuntu)

Hi everyone. A little bit of backstory:

I have two Ubuntu 18.04 machines, both of which have R installed on them with rJava, xlsx, and xlsxjars libraries installed. If I am on machine A, I can call library(xlsx) fine and use it without any issues, HOWEVER, when I am on machine B I get the following baffling message:

> library(xlsx)
Error: package or namespace load failed for ‘xlsx’:
 .onLoad failed in loadNamespace() for 'xlsx', details:
  call: fun(libname, pkgname)
  error: Your java version is 11.0.3.  Need 1.5.0 or higher.

Running java -version on Machines A and B return the same value:

OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode, sharing)

If someone can help with figuring out why machine B's xlsx library doesn't recognize version 11.0.3 as higher than 1.5.0 that will be greatly appreciated.

Thanks!