Cannot log in to AWS RStudio Server and Workbench, instead see 'Error: Unauthorized user.'

Hi there.

When starting an RStudio Server/Workbench from AWS Marketplace, and visiting http://<ec2_instance_public_dns>:8787, I see the login screen as expected. However, I cannot log in.

I first followed the instructions and used "rstudio-user" as the username and the instance id as the password. But I see:

I tried many other combinations:

u: rstudio-user p: instance_id (with and without the first two characters, i.e. i-029d67d91f5fba428 and 029d67d91f5fba428
u: rstudio p: rstudio
u: rstudio-user p: rstudio-user

And a few other combinations, but I cannot get in.

I briefly shelled in and toyed around with a few things but I'm stabbing in the dark at this point.

Any ideas why the simple u: "rstudio-user" (or u: rstudio-user, if the double double quotes were a typo) and p: instance_id don't work?

Note: I tried this twice, first with the AWS marketplace RStudio Server image, second with the RStudio Workbench image, and had the same problem with both. If anyone wants to try to reproduce the problem, it should only take ~2 minutes to fire up a new instance and reproduce.

Hi, I tried a few more times, the documentation seems to be very wrong:

(the username/password suggested in the documentation simply doesn't work).

Is anyone able to start an RStudio instance from AWS marketplace? I suspect this would be a problem not just for me but for anyone who tries.

I got help in another forum, they said to shell in and try

sudo useradd youruser
sudo passwd youruser

After doing so, I tried logging in to the instance and it appeared to login and load for a moment before:

I shelled in again and ran sudo reboot and tried again to login, but same again.

I am really curious if anyone can make this work if it's broken?