Cannot see output when making site with blogdown

I'm currently facing an issue where my .Rmarkdown pages are being rendered fine, except I do not see any output being displayed at all. No plots, no tables, nothing. I think somehow, my fig.path has been messed up.

The output for the line knitr::opts_chunk$get('fig.path') is ## [1] "index_files/figure-html/"
How do I fix the problem and reset the fig.path to default? Currently, I see no output being displayed at all, only code chunks.

My repo is hosted here: https://github.com/thedivtagguy/website if this helps.
Live website deploy: https://thedivtagguy.netlify.app/

I think this is because you are missing this in your config

markup:
  goldmark:
    renderer:
      unsafe: true

If you add it, it should render ok.

See https://github.com/rstudio/blogdown/issues/447

If you look at your markdown source file, you'll see the resulting plot and table are included using HTML directly inside your markdown document. https://raw.githubusercontent.com/thedivtagguy/website/master/content/post/2020-12-20-food-and-nutrition/index.markdown

Hugo will ignore raw HTML by default. This is something we could not change, but just strongly advice to set this option unsafe to TRUE for goldmark renderer.
This issue will not happen when you use Rmd file as they will be generated using Pandoc and not Goldmark.

We've recently added some check function to give all the advice we have for a website. If you install the dev version, you can run blogdown::check_site(). I think you are missing other configuration so it could be useful to you.

remotes::install_github('rstudio/blogdown')

More on these check functions in here: https://alison.rbind.io/post/2020-12-27-blogdown-checks/