Cannot type umlaut (äöü) in R Studio on one of two computers with identical R and RStudio


#1

I have two computers with Win10 pro 64 and the same versions of R and RStudio installed.

On one computer, I cannot type umlauts like "üäö" in the RStudio console.

comuter 1: >üäö

computer2: >ZZZ

I've been trying to solve that problem for hours now. Has anybody had the same problem?

These are the installation details (same on both computers):

version _
platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
status
major 3
minor 4.3
year 2017
month 11
day 30
svn rev 73796
language R
version.string R version 3.4.3 (2017-11-30) nickname Kite-Eating Tree

RStudio:

    RStudio.Version() $citation

To cite RStudio in publications use:

RStudio Team (2016). RStudio: Integrated Development for R. RStudio, Inc., Boston, MA URL http://www.rstudio.com/.

A BibTeX entry for LaTeX users is

@Manual{, title = {RStudio: Integrated Development Environment for R}, author = {{RStudio Team}}, organization = {RStudio, Inc.}, address = {Boston, MA}, year = {2016}, url = {http://www.rstudio.com/}, }

$mode [1] "desktop"

$version [1] ‘1.1.442’

Sys.getlocale() gives on both computers

[1] "LC_COLLATE=German_Switzerland.1252;LC_CTYPE=German_Switzerland.1252;LC_MONETARY=German_Switzerland.1252;LC_NUMERIC=C;LC_TIME=German_Switzerland.1252"

I tried to:

reinstall R

reinstall RStudio

language for unicode incompatible programs is set to "Detusch (Schweiz) on both computers

Reopen with Encoding is set to UTF-8 on both computers.

#2

Found the reason: Editor Font in >Tools>Global Options>Appearance was strangely set to "8514oem"... everything works well with "Lucida Console" :smiley:


#3

Yay! Glad you figured it out. Since you've figured it out, would you mind just marking your answer as the solution? (see FAQ below for how) It makes it a bit easier to visually navigate the site and see which questions still need help.

Thanks