Cannot view example application at URL after setting up shiny server

I am attempting to install Shiny Server on CentOs linux, where I also run hosted Rstudio.I followed the instructions here and installed the rpm file.

I then went to the quickstart guide.

Under 7.1.1 'Host a directory of applications' I ran this code snippet:
sudo /opt/shiny-server/bin/deploy-example default

This results in:

Installing sample apps...
/srv/shiny-server/index.html already exists. Not overwriting.
/srv/shiny-server/sample-apps already exists. Not overwriting.
Done installing samples.
Restarting Shiny Server...
Waiting...

The default config is all setup now. Enjoy!

'I then navigated to http://my_actual_domain_name:3838/sample-apps/hello/' and I get a timed out error message.

How can I view the example shiny app? More generally, is there anything I can do to troubleshoot here? I was expecting to see the application when I navigated to that URL.

I do see the example app created per the guide:

total 0
lrwxrwxrwx 1 root root 38 Sep 27 20:31 index.html -> /opt/shiny-server/samples/welcome.html
lrwxrwxrwx 1 root root 37 Sep 27 20:31 sample-apps -> /opt/shiny-server/samples/sample-apps
[my_domain_name ~]$

Have you make sure that you have enabled remote access to 3838 port in your server?

Hi thanks for the tip. How would I check that?
Tried:

(Just to see what it looks like for RStudio server which I know is already up and running)
[myname@myserver ~]$ grep -w 8787 /etc/services

msgsrvr         8787/tcp                # Message Server
msgsrvr         8787/udp                # Message Server

(Just to see what it looks like for a nothing port)
[ec2-user@prd1glubibi-rproject-1 ~]$ grep -w 8788 /etc/services

(Checking for 3838 for shiny server)
[myname@myserver ~]$ grep -w 3838 /etc/services

sos             3838/tcp                # Scito Object Server
sos             3838/udp                # Scito Object Server

[myname@myserver ~]$

Does this tell us?

It looks like you are using an AWS EC2 instance, so you would have to open 3838 port on the AWS console, go to "Security Groups" and set your inbound rules

Ah, right. Thanks for the tip. Pinged our admins to open port 3838