Can't install dplyr package anymore:( pls help! Rcpp error?

I've never had problems installing dplyr in the past, but whenever I try I get the following message:

Error: package or namespace load failed for ‘dplyr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘Rcpp’ 1.0.0 is being loaded, but >= 1.0.1 is required

I have tried using both of the following commands with no luck:

library(dplyr)
install.packages("dplyr")

Have you tried upgrading your Rcpp package? The latest version seems to be 1.0.5. Try

install.packages("Rcpp")

Since you are using a very old R version, packages are only available in source form which requires compilation. For compiling packages on macOS you need to install Xcode in your system (not in R) and the recommended development tools for macOS systems.
https://cran.r-project.org/bin/macosx/tools/

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

Yes, sorry I forgot to mention that. I get this message in return and still am unable to install dplyr:

installing the source package ‘Rcpp’

trying URL 'https://cran.rstudio.com/src/contrib/Rcpp_1.0.5.tar.gz'
Content type 'application/x-gzip' length 2950521 bytes (2.8 MB)

downloaded 2.8 MB

  • installing source package ‘Rcpp’ ...
    ** package ‘Rcpp’ successfully unpacked and MD5 sums checked
    ** libs
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    ERROR: compilation failed for package ‘Rcpp’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/Rcpp’
  • restoring previous ‘/Library/Frameworks/R.framework/Versions/3.5/Resources/library/Rcpp’
    Warning in install.packages :
    installation of package ‘Rcpp’ had non-zero exit status

The downloaded source packages are in
‘/private/var/folders/vs/6ys1l1057kj9kdbs3jkfr07m0000gn/T/RtmpkZrQda/downloaded_packages’

Thanks for your suggestion, but it still didn't work:( I still get the same error message