Can't load package 'car'

I can't load package car, apparently due to a version issue (vctrs). See code below.

library(car)
Loading required package: carData
Error: package or namespace load failed for ‘car’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘vctrs’ 0.1.0 is being loaded, but >= 0.2.1 is required
In addition: Warning messages:
1: package ‘maxLik’ was built under R version 3.6.2
2: package ‘miscTools’ was built under R version 3.6.2
3: package ‘car’ was built under R version 3.6.2
4: package ‘carData’ was built under R version 3.6.1

I'm using RStudio Version 1.2.1335, and R 3.6.0

Hi, and welcome!

To improve your chances of a successful installation, it will help to be at R version 3.6.2. Once you are

install.packages(c("vctrs","maxLik","miscTools","car","carData"))

then try

library(car)

again. If that doesn't work, please post

sessionInfo()
1 Like

Thank you. That has resolved the problem.

Curious if you wouldn't mind marking this response as a solution? FAQ: How do I mark a solution?

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.