Can't open Rstudio on Xenial

linux
ubuntu

#1

Hi all,

I just tried to install Rstudio on xenial. I first tried these instructions: https://askubuntu.com/questions/1013160/how-to-install-r-on-ubuntu-16-04-xenial

But then I couldn't find a version of Rstudio that was labelled xenial on the Rstudio site. So I used the commands in the install Rstudio section of this guide: https://gist.github.com/mGalarnyk/41c887e921e712baf86fecc507b3afc7

After that, I could use R in the command line, but I couldn't open Rstudio, either by typing 'rstudio' into the terminal or by clicking the icon from applications.

So I went back to the first guide and ran the commands in step two, but nothing changed. Right now, if I type 'rstudio' into the terminal I get this message: rstudio: error while loading shared libraries: libxslt.so.1: cannot open shared object file: No such file or directory

Any idea how I can fix this and use Rstudio?


#2

Hi @houn_portus! Welcome!

Here’s the preferred installation method for xenial (click to expand):

Note that the binary isn’t labeled “xenial” on the download page, it’s labeled “Ubuntu 16.04+” (xenial = 16.04).


#3

Hi, thanks for your help, unfortunately, I tried this and was not successful. After downloading rstudio-xenial-1.1.463-amd64.deb, when I try to run:

sudo apt-get install gdebi-core sudo gdebi rstudio-xenial-1.1.463-amd64.deb

from my downloads folder, I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package rstudio-xenial-1.1.463-amd64.deb
E: Couldn't find any package by glob 'rstudio-xenial-1.1.463-amd64.deb'
E: Couldn't find any package by regex 'rstudio-xenial-1.1.463-amd64.deb'

Because I could see the package in my downloads, I didn't understand what was going wrong. So, I tried to use the GDebi Package Installer, which didn't throw any errors, but when it finished it said status: same version already installed. But, I still can't seem to open Rstudio either from the command line or from applications.

I then uninstalled the package, which removed the rstudio icon from my applications, then reinstalled it, but with the same results.

Any idea what is going wrong?


#4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.