Can't publish bookdown after update

I recently updated my RStudio and before the update, I could easily publish my bookdowns at, by just clicking the publish button.

Now, when I click this button I get the message that " is Not Registered", telling me that I don't have any accounts registered on that server. I then try to configure a bookdown account in my system, by running bookdown::publish_book(render = "local") which prompts me to authenticate the connection in my browser. After the authentication is done, I get

You've successfully connected the rsconnect package to RStudio Connect! If you're using the RStudio IDE, click the "Connect Account" button to finish adding this account.

Now you are ready to publish a Shiny application, R Markdown documents or any plot created with R.

Then, in RStudio again, I go to global options > publishing > connect (no account is shown there), and the window asks me for my RStudio connect server URL, which I don't have and I continue to not be able to publish my bookdowns. I am new to RStudio connect so I'm not quite sure about what I'm doing wrong, shouldn't my bookdown account just be authenticated without the need of connecting to RStudio connect?

I have restarted R, RStudio, and the computer a few times but I still have no connection to

Can you try log in in ?

There is a button in the menu. Can you access the server and see your publications ?

The process you followed seems to be the right one. Maybe something has changed.

I can indeed, and I can see my only currently published bookdown (which is the one I'm trying to update at the moment)

You can try connecting your rstudio IDE manually using the setting and the server url which should be

That way you can check that rstudio is correctly retaining the connection information.

Thanks @cderv. When I do that, RStudio opens the browser, I make the authentication and I get the same message as before, that I can return to RStudio and click "Connect Account". After that, RStudio doesn't update, it just keeps waiting for me to make the authentication. Is that the expected behaviour?

It seems there is something wrong happening on the network, the API calls, between the IDE and the server. Unfortunately I don't have much more idea right now.

Are you using a recent RStudio version ?

Once you click connect account, it should be synced to RStudio IDE and at some point you should see the server configured in your IDE.

I'll try to reproduce on my side when I can.

Thanks @cderv! My RStudio version is 1.4.1717

Thank you for explaining, unfortunately my RStudio IDE does not react to me connecting to bookdown in the browser :confused:

Just an update, this seems to be a problem with my computer rather than RStudio, I've tried authenticating other apps in the browser (Chrome and Safari) and that didn't work either.

1 Like

Good try. That indeed needs to work also in browser. I can't help you more I guess. Maybe you have firewall or other security thing where you connect.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.