Can't save preferences on RStudio in MacOS Catalina

Hello,

After updating to MacOS Catalina, I'm unable to save any preferences (e.g. Snippets or Themes) in RStudio. I've updated all permissions, including giving RStudio full disk access and Accessibility controls, and still get a saving error. Some more information on the problem:

> sessionInfo()
R version 3.6.3 (2020-02-29)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Catalina 10.15.7

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.6.3 tools_3.6.3   

MYUSER@MY-MBP ~ % stat -l ~/.rstudio-desktop ~/.R
drwxrwxrwx 22 MYUSER staff 704 Oct 16 09:28:26 2020 /Users/MYUSER/.rstudio-desktop
drwxrwxrwx 5 MYUSER staff 160 Jun  5 16:26:33 2020 /Users/MYUSER/.R

Running RStudio Desktop Version 1.3.1093

Appreciate any help on this and apologize if I'm missing some information required to solve this. Cheers

All those things are saved to the ~/.config/rstudio folder in RStudio 1.3. Are you able to create content in that folder from the Terminal?

% touch ~/.config/rstudio/foo

You might also try renaming that folder, if it exists, and letting RStudio auto-create it again.

1 Like

This worked, I did not have the right permissions on that folder. Thanks a lot!

No problem, glad that's all it was!