Change RStudio Server Quarto version

I'm struggling to specify which quarto version should be used across all RStudio Server instances. Following this thread ( How to update Quarto version installed with Rstudio - RStudio IDE - Posit Community, I've tried the following things:

  • Add quarto folder to PATH (`export PATH="/software/quarto/bin:$PATH")
  • Check if it worked (which quarto)
  • Install rstudio-server via dnf install rstudio-server-rhel-2023.09.1-494-x86_64.rpm
  • Add R binary in /etc/rstudio/rserver.conf via rsession-which-r

However, when I launch an RStudio Server Session and type quarto check in the terminal, it still points to the bundles quarto version.

How can I fix this?

Hi @DBScan sorry for the confusion! Could you try symlinking the quarto version that you desire and see if that fixes the issue? Some instructions here:

1 Like

Hi @tnederlof , this worked! Is this the correct way to handle it? For instance, in rsession.conf I tried to specify external-quarto-path, but this seemed to have no effect.

Yes, I believe this is the best way, as it will route to the version you want in terminal sessions as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.