Content of Rscript gone after updating

I was updating my Rstudio few days ago, to the latest version 2022-04-19, then I used the updated Rstudio to open my rscript which I saved it using the old version, all the content gone, blank white. All of my Rscript face the same problem, but I look at the size of the Rscript, it wasn't 0KB, which means the content is still in there, somehow it just won't pops up. I couldn't even save new Rscript, the size just keep remaining 0KB eventhough I press the save button.

Does someone knows how to fix this? Thanks in advance

I think you might be hitting this issue:

Can you confirm that you're using R 4.2 w/ a non-default encoding? You can also try a build of RStudio with the fix here:

Thank you for your reply, I've tried to reopen the script with encoding UTF-8 and the content reappear. I tried to choose "save with encoding" UTF-8, but when I reopen the script, the content went blank, and I have to reopen it with encoding UTF-8 again.

In the meantime, I am facing another problem, I open a new R script, type in a few codes or something and tried to save it. When I wrote on the 1 line, saved, the size of the script changes, normal. Second line, saved, the number of the size increased, normal. However when it comes to line 5-7, saved, the size turn back to 0 B ?????? I have no idea what is going on. I am feeling real depressed, I felt that this software is been giving me all kinds of problems since I updated it. :sob: :sob:


Did you try this suggestion ?

Thanks again, I solved it. I uninstall and reinstall it, but still have no idea why this didn't work a few days before. Anyway, problem solved, Rscript can open and save normally again without changing the encoding. Thank you very much for your help.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.