Continuous crash on RStudio server

rstudio
rstudioserver
crash-report

#1

Hi everyone,

I was using RStudio server on our machine and in one day it started to behave very strangely and now it is nearly impossible to work.
Approximately at every command, there is a pop-up with "No such file or directory", however the command executes. Also relatively frequently, it just crashes.

rstudio-server status gives back these 2 lines (in several copies):
Dec 05 14:21:19 behserver.nibb.ac.jp rsession-peegee[19350]: ERROR system error 2 (No such file or directory); OCCURRED AT: rstudio::core::Error rstudio::session::source_database::get(const std::string&, bool, rstudio_boost::shared_ptr<rstudio::session::so...base.cpp:644; LOGGE

Dec 05 14:21:39 behserver.nibb.ac.jp rsession-peegee[20043]: ERROR session hadabend; LOGGED FROM: rstudio::core::Error<unnamed>::rInit(const rstudio::r::session::RInitInfo&) /root/rstudio/src/cpp/session/SessionMain.cpp:563

I tried to restart rstudio server, also deleting my ~/.rstudio and restart, but it keeps doing. Any suggestion is highly appreciated!


#2

This usually implies that the source database RStudio uses for its own local cache of open documents has been corrupted in some way. This cache is located in the user's home directory, at ~/.rstudio.

This is a more generic "R crashed" message.

My guess is that R sessions are crashing, and then are either losing access to, or somehow corrupting, the existing source database. Do you have any guess as to what is causing the R session crashes? (It could be due to incompatibilities in packages installed, or errors in one or more packages causing a segfault during operation)


#3

Thank you for the answer.

I tried to clean up to see if it will be fixed. I deleted my ~/.rstudio, suspended all R sessions and updated R (3.5.0 -> 3.5.1). Unfortunately it is still crashing. I used only pale R and tidyverse, nothing "fancy" package in this time. I realized it will definitely crash when there is an error message from the code.


#4

What version of RStudio Server are you using? You might try and see if you have better luck with the v1.2 preview release.