CURL_OPENSSL_3 not found

ubuntu

#1

System details

RStudio Edition : Desktop
RStudio Version : 1.1.456 
OS Version      :  Ubuntu 18 LTS
R Version       :  3.4.4

I updated from Ubuntu 16 LTS to 18 LTS that seems to have broken something.

Steps to reproduce the problem

> devtools::install_github("shaunpwilkinson/insect")
Installation failed: unable to load shared object '/home/ubuntu/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so':
  /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /home/ubuntu/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/curl.so)

Describe the problem in detail

Installing and uninstalling the "curl" package did not help.
Installing install.packages("RCurl") did also not help.

Does not work:

ubuntu@master:~$ sudo apt install libcurl3 libcurl-openssl1.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cdbs dh-translations intltool jq libblas-dev libblas3 libbz2-dev libjpeg-dev
  libjpeg-turbo8-dev libjpeg8-dev libjq1 liblapack-dev liblapack3 liblzma-dev
  libncurses5-dev libonig4 libpng12-dev libreadline-dev libssl-doc
  libtinfo-dev python3-scour r-doc-html scour
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libssl1.0-dev
The following packages will be REMOVED:
  curl libcurl4 libcurl4-openssl-dev libssl-dev r-base r-base-core r-base-dev
  r-base-html r-cran-boot r-cran-class r-cran-cluster r-cran-codetools
  r-cran-foreign r-cran-kernsmooth r-cran-lattice r-cran-mass r-cran-matrix
  r-cran-mgcv r-cran-nlme r-cran-nnet r-cran-rpart r-cran-spatial
  r-cran-survival r-recommended
The following NEW packages will be installed:
  libcurl-openssl1.0-dev libcurl3 libssl1.0-dev
0 upgraded, 3 newly installed, 24 to remove and 21 not upgraded.
Need to get 1.659 kB/1.873 kB of archives.
After this operation, 60,0 MB disk space will be freed.
Do you want to continue? [Y/n] 


#2

At the bottom of that script it says Do you want to continue? [Y/n], did you choose one of these.

I'm not on Ubuntu, but it looks like people have had problems with libcurl4 conflicting with libcurl3, resulting in the CURL_OPENSSL_3 issue.

https://bugs.launchpad.net/ubuntu/+source/curl/+bug/1754686

I believe there's a workaround in this thread:


#3

No that doesn't work. As you can see R is being uninstalled if I try to install libcurl3.

from first post:

The following packages will be REMOVED:
  curl libcurl4 libcurl4-openssl-dev libssl-dev r-base r-base-core

And if I install libcurl3 and afterwards R, libcurl gets updated to 4 automatically.

And besides that I am not trying to run some kind of "old application that has been compiled under Ubuntu 14 LTS" it's a brand new R installation with the most recent RStudio.


#4

The most recent version of R is 3.5.1.

Is this just a random example of trying to install something with devtools and it not working? Did you try installing it from CRAN?

Either way, it looks like something is trying to access CURL_OPENSSL_3, which isn't there.

I'm out of suggestions, but hopefully someone else can help you out.