Customized shortcuts not working on Windows


#1

I'm trying to remap the following commands to new shortcuts:

To Lowercase -- Ctrl+Shift+L
To Uppercase -- Ctrl+Shift+U

To resolve conflicts, I removed the pre-existing assignments, so that my two configuration files look like this:

editor_bindings.json

{
    "expandtoline" : "",
    "tolowercase" : "Ctrl+Shift+L",
    "touppercase" : "Ctrl+Shift+U"
}

rstudio_bindings.json

{
    "devtoolsLoadAll" : "",
    "yankBeforeCursor" : ""
}

However, the shortcuts do nothing. I tried restarting RStudio, to no avail. Any help appreciated.

Technical details:
Windows 10, 64 bits
RStudio 1.1.453
Keybindings option : default


#2

How do you switch between languages (e.g., English-other_language)? I had similar problem because Ctrl+Shift was mapped globally to switch language and all of the shortcuts (not only in RStudio, but, e.g., in IntelliJ) were not working correctly.


#3

I wish it was the case, but my language shortcut is Alt-Shift. I use the Ctrl-Shift-U and Ctrl-Shift-L in other text editors (NP++ and others) without any problems.


#4

Thanks for the bug report! This was in fact an issue distinct to the tolowercase and touppercase commands -- we had historically disabled these commands as they had conflicted with separate bindings we attempted to impose, but with more recent changes to the command dispatch system in RStudio it should now be possible for these commands to more easily coexist. Unfortunately, the UI was showing this command despite that we originally disabled it!

You should see the fix become part of the next daily builds (hopefully by the end of the day).


#5

Excellent! Just tried the latest build, and indeed, it works. Thanks!