Db connection not showing up in Rstudio connections pane

Hello- I am successfully connecting/ writing/ reading to/from a local MariaDB connection; eg:

con <- DBI::dbConnect(RMySQL::MySQL(), username="das_user_mensch", password="", dbname ="datawarehouse", host="localhost")

works like a charm.

But nothing shows up in my local Rstudio Desktop connections pane, even though this fine article from Rstudio suggests that it should happen automatically.

I'd love any troubleshooting advice to correct this.

Session info
devtools::session_info()
#> ─ Session info ──────────────────────────────────────────────────────────
#>  setting  value                       
#>  version  R version 3.5.2 (2018-12-20)
#>  os       macOS Mojave 10.14.2        
#>  system   x86_64, darwin15.6.0        
#>  ui       X11                         
#>  language (EN)                        
#>  collate  en_US.UTF-8                 
#>  ctype    en_US.UTF-8                 
#>  tz       America/Chicago             
#>  date     2019-02-13                  
#> 
#> ─ Packages ──────────────────────────────────────────────────────────────
#>  package     * version date       lib source                     
#>  assertthat    0.2.0   2017-04-11 [1] CRAN (R 3.5.0)             
#>  backports     1.1.2   2017-12-13 [1] CRAN (R 3.5.0)             
#>  callr         2.0.4   2018-05-15 [1] CRAN (R 3.5.0)             
#>  cli           1.0.1   2018-09-25 [1] CRAN (R 3.5.0)             
#>  crayon        1.3.4   2017-09-16 [1] CRAN (R 3.5.0)             
#>  debugme       1.1.0   2017-10-22 [1] CRAN (R 3.5.0)             
#>  desc          1.2.0   2018-07-09 [1] Github (r-lib/desc@4f60833)
#>  devtools      2.0.1   2018-10-26 [1] CRAN (R 3.5.1)             
#>  digest        0.6.18  2018-10-10 [1] CRAN (R 3.5.0)             
#>  evaluate      0.10.1  2017-06-24 [1] CRAN (R 3.5.0)             
#>  fs            1.2.6   2018-08-23 [1] CRAN (R 3.5.0)             
#>  glue          1.3.0   2018-07-17 [1] CRAN (R 3.5.0)             
#>  htmltools     0.3.6   2017-04-28 [1] CRAN (R 3.5.0)             
#>  knitr         1.20    2018-02-20 [1] CRAN (R 3.5.0)             
#>  magrittr      1.5     2014-11-22 [1] CRAN (R 3.5.0)             
#>  memoise       1.1.0   2017-04-21 [1] CRAN (R 3.5.0)             
#>  pkgbuild      1.0.2   2018-10-16 [1] CRAN (R 3.5.0)             
#>  pkgload       1.0.2   2018-10-29 [1] CRAN (R 3.5.0)             
#>  prettyunits   1.0.2   2015-07-13 [1] CRAN (R 3.5.0)             
#>  processx      3.1.0   2018-05-15 [1] CRAN (R 3.5.0)             
#>  R6            2.3.0   2018-10-04 [1] CRAN (R 3.5.0)             
#>  Rcpp          1.0.0   2018-11-07 [1] CRAN (R 3.5.0)             
#>  remotes       2.0.2   2018-10-30 [1] CRAN (R 3.5.0)             
#>  rlang         0.3.1   2019-01-08 [1] CRAN (R 3.5.2)             
#>  rmarkdown     1.9     2018-03-01 [1] CRAN (R 3.5.0)             
#>  rprojroot     1.3-2   2018-01-03 [1] CRAN (R 3.5.0)             
#>  sessioninfo   1.1.1   2018-11-05 [1] CRAN (R 3.5.1)             
#>  stringi       1.2.4   2018-07-20 [1] CRAN (R 3.5.0)             
#>  stringr       1.3.1   2018-05-10 [1] CRAN (R 3.5.0)             
#>  testthat      2.0.0   2017-12-13 [1] CRAN (R 3.5.0)             
#>  usethis       1.4.0   2018-08-14 [1] CRAN (R 3.5.0)             
#>  withr         2.1.2   2018-03-15 [1] CRAN (R 3.5.0)             
#>  yaml          2.1.19  2018-05-01 [1] CRAN (R 3.5.0)             
#> 
#> [1] /Library/Frameworks/R.framework/Versions/3.5/Resources/library

Unfortunately, Connection Contract does not work for this :package: yet.

See


and

You won't see anything in the connection pane. The connection pane is working with odbc :package: for the moment, and other which have implemented the connnection contract

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.