Deploying app to with Python

Hello. I am able to deploy to, but when I try to update an existing app, it will instead create a new version. So instead of updating "myapp", it will create "myapp1".

I tried to use --app-id with rsconnect, and the titles are the same, so I don't know what else to do.

We've been trying to reproduce this issue internally here at Posit, using several versions of rsconnectfor Python, but we haven't been able to recreate the problem you report.

What version of rsconnect are you using? You can run rsconnect version where you would usually be running the deploy to check.

Can you confirm you're running a command like this?
rsconnect deploy shiny /path/to/source-dir --name shinyapps-account-name or
rsconnect deploy shiny /path/to/source-dir --name shinyapps-account-name --title AppName

After a successful deployment, rsconnect drops some state files on disk for the purpose of ensuring future deployments update the existing application, instead of creating a new one. If your application is on your machine at /path/to/source-dir, the relevant file is at /path/to/source-dir/rsconnect-python/AppName.json. Can you check if you have this file, and if so, what it says for app_id?

I am using this one:

"rsconnect deploy shiny /path/to/source-dir --name shinyapps-account-name --title AppName"

Right now it says app_id: 9230509

When I tried to run it again it changed to app_id: 9257459 and it created a copy like last time. However the name of the JSON file stayed the same.

I was on version 1.13, however, I updated to 1.17 and I am having the same issue.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.