deploying to shinyapps.io halted, reticulate in use, python not specified

I'm deploying an app to shinyapps.io, but it halts with the error "reticulate is in use, but python was not specified". When I check the dependencies ("rsconnect::appDependencies()") I see reticulate there, but I can't find a reference to python / don't know where to look for that. What do I do to deploy to shinyapps.io?

Take a look at this

Thanks! However, I don't know what Python package is needed. Reticulate is probably called for from another package, but I don't know which. The packages used in my app are pdftools, tm, quanteda, wordcloud, topicmodels and LDAvis.

This could be a bug in rsconnect, ckeck this related issue on github

I am having the same issue. I have tried specifying my python to 3.7 and downloading an old version of rsconnect. Please let me know if you make any progress.

You have to try specifying the python version available at shinyapps.io (2.7 or 3.5) not the python version that is available in your system

I removed rsconnect and installed a previous version:

devtools::install_github("rstudio/rsconnect", ref='737cd48')

and then did rsconnect again. After that I got some errors deploying, but they were unrelated (solved that by updating my R from 3.5.1 to 3.5.2, which my packages were made for). After fixing that it worked.

I got mine to work when I put the correct python directly in the project folder. It wouldn't work when it was in a different folder oddly enough.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

There was an issue with the rsconnect package, and this was fixed in a Pull Request (https://github.com/rstudio/rsconnect/pull/332) to the package.

Try to install rsconnect from github using remotes::install_github("rstudio/rsconnect").

This resolved the issue for me.