DescToolsAddins package: kbd shortcut for Desc() fails...

Hi all!.

Installed and loaded pkgs:

  • DescTools and
  • DescToolsAddins

All my kbd shortcuts
for DescToolsAddins pkg work fine:

  • CTRL+H = Head(iris) OK!
  • CTRL+Y = Summary(iris) OK!
  • CTRL+T = Str(iris) OK!

...except for

  • CTRL+E = Desc(iris)
    which fails with Error message:

> Desc(iris)
Error in getExportedValue(pkg, name) :
cannot open file '~/R/i686-pc-linux-gnu-library/3.5/DescTools/data/Rdata.rdb': No such file or directory
In addition: There were 21 warnings (use warnings() to see them)

Rstudio 1.1.463
R 3.5.1
Linux Ubuntu 14.04 LTS 32bits.

R version 3.5.1 RC (2018-06-24 r74934)
Platform: i686-pc-linux-gnu (32-bit)
Running under: Ubuntu 14.04.6 LTS

Matrix products: default
BLAS: /usr/lib/libblas/
LAPACK: /usr/lib/lapack/

[1] LC_CTYPE=en_US.UTF-8
[3] LC_TIME=en_US.UTF-8
[7] LC_PAPER=en_US.UTF-8

attached base packages:
[1] graphics grDevices utils datasets stats
[6] methods base

other attached packages:
[1] DescToolsAddIns_1.1 tidylog_0.1.0.9000
[3] wrapr_1.8.5 editheme_0.1.0
[5] default_1.0.0 DescTools_0.99.28
[7] skimr_1.0.5 visdat_0.5.3.9000
[9] ggplot2_3.1.0 dplyr_0.8.0.1

loaded via a namespace (and not attached):
[1] R6_2.4.0 expm_0.999-4
[3] scales_1.0.0 assertthat_0.2.1
[5] grid_3.5.1 tcltk_3.5.1
[7] styles_0.1.0 manipulate_1.0.1
[9] tidyselect_0.2.5 munsell_0.5.0
[11] pillar_1.3.1 compiler_3.5.1
[13] tibble_2.1.1 lattice_0.20-38
[15] pkgconfig_2.0.2 boot_1.3-20
[17] purrr_0.3.2 Matrix_1.2-17
[19] rstudioapi_0.10 MASS_7.3-51.1
[21] plyr_1.8.4 glue_1.3.1
[23] magrittr_1.5 gtable_0.3.0
[25] rlang_0.3.2 colorspace_1.4-1
[27] yaml_2.2.0 tools_3.5.1
[29] foreign_0.8-71 mvtnorm_1.0-10
[31] withr_2.1.2 lazyeval_0.2.2
[33] crayon_1.3.4 Rcpp_1.0.1


Is your installation of DescTools working ? Can you run the functions without the addins ?

Try library(DescTools) and Desc(iris)

cannot open file '~/R/i686-pc-linux-gnu-library/3.5/DescTools/data/Rdata.rdb': No such file or directory

This means that there is something wrong with the installation of DescTools. You could try to reintall it properly. Did you already try that?

Hi Christophe,

thanks for helping out!.

In the default Rstudio:
if I do:
library(DescTools) # and then do:
it WORKS!. :slight_smile:

  • Now, suppose I create in Rstudio a totally new Project, called: "WA".

  • I switch in Rstudio to the new WA Project.

  • I do :
    in the new WA Project: It WORKS! :slight_smile:

It works fine using either:

  • Desc(iris)
  • the keyboard shortcut: CTRL+E
  • the Desc command from the Addins dropdown Menu.


So finally, in both:
Project(None) or in Project: WA,
the Rstudio Packages panel should show only:
[X] DescTools as "loaded",
but do NOT load:
[ ] DescToolsAddins.

I thought
I needed to LOAD both packages...Nope!.
Seems only DescTools should be loaded
and everything will work fine...

Why should only the pkg: DescTools
be required for everything to work ok,
but no need to load the pkg: DescToolsAddins?.
(leave that PKG UNchecked / not loaded...).

(I may be missing a fundamental concept here, Christophe).

San Francisco

I think this is because the DescToolsAddins only provide the addins feature for RStudio IDE and when you call the Addin, it calls what is required without you, the user, to explicitly load the library. It is how addins works.

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

1 Like

Thank you, Christophe!.
Your explanation makes 100% sense.
Marked as "Solution", as required.

If I may,
one last quick question:
how to automatically "load"
the DescTool pkg
into the new WA Project?,
(instead of my typing:
> library(DescTool)
every rime I switch to the WA Project?).

Appreciate your help! Thank you!.

I believe the good practice is to load the library with ˋlibrary()` at the beginning of your script. It is the better way to insure reproductible code.

1 Like

Thank You / Merci Christophe,
for all your effective
and very clear help.

Have a nice evening!.
San Francisco

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.