devtools::check() produces warning when checking Rd files

Hi RStudio Community!

I'm working on a package, and when I run devtools::check() I get the following warning, but I'm not sure why this happens:

❯ checking Rd files ... WARNING

When troubleshooting, the only way I can get the warning to disappear is by deleting all R code and roxygen documentation in the package. I've also tried to run devtools::check() on a package created in RStudio by doing the following:

File > New Project > New Directory > R Package

and gotten the same results even before I changed any of the default code.

I know it's a warning and it's most likely safe to ignore, but I'm curious what's going on here. Is this behavior a feature or a bug? And, if it's a feature, can anyone help me understand what's going on with it?


Reported at rcmdcheck: `devtools::check()` creating warning that only contains `NULL` · Issue #184 · r-lib/rcmdcheck · GitHub

This topic was automatically closed after 45 days. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.