I've been having trouble getting the recent shiny server to work (using Ubuntu .deb installed with gdebi). I am getting "Not Founds" on situations where a directory with index.Rmd should be served by default. The regular app.R, etc shiny apps work fine. It also works fine being explicit with the URL and including "index.Rmd". But "directory_index on" (the default) doesn't seem to be doing its job entirely.

As a reprex, go get the recent rocker/shiny-verse docker image (which uses the same .deb I do). Run it and you'll see a "Not Found" in the lower right part of the Shiny welcome page, because that iframe sources a directory. Change the index.html to have that URL instead include "index.Rmd" as mentioned by Dirk here:

and you'll see what you're supposed to. Is there some setting I'm missing or some basic thing?


Is this a Shiny Rmd? What version of rmarkdown are you using? This sounds very much like a RMarkdown bug that was on CRAN for a bit (in 1.18 I think?), but the latest from CRAN resolves:

Note that directory_index on has nothing to do with serving index.Rmd, etc. directory_index on allows users to "see" the list of applications available in a given folder by navigating to the folder URL. This is a fairly consistent paradigm with file servers, and is an analog that you may be familiar with from CRAN, for instance:

I upgraded it and yes that worked. Sorry to maybe throw you off then. index.Rmd files are now working as they should and directory_index works as it should. Thanks.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.