disable blinking cursor

This might sound strange, but every once and a while the cursor in my editor pane will resume blinking despite Tools / Global Options / Code / Display / Blinking cursor being unchecked. It does not blink in the console pane.

It is probably a trivial problem for most users, but it completely breaks my concentration.

I have tried a new daily build, but the problem persists.

Any tips or solutions would be much appreciated!

1 Like

Thanks for the bug report!

It may be difficult, but can you provide us with a reproducible example? Unfortunately, unless we can reproduce the issue on our end we may be unable to fix the problem.

1 Like

Kevin,

Thanks for the reply! I will try to reproduce it if I can. Unfortunately, it is intermittent, and I cannot for the life of me isolate it enough to reproduce. I was (selfishly) hoping that it was a known issue. Should this change, I'll post again.

Thanks again,
Travis

Blinking cursors break my concentration as well. I unchecked Blinking cursor, but the blinking resumed in the editor. I stumbled across a solution in Windows 10.

Control Panel / Keyboard / Keyboard Properties, and set the Cursor blink rate to None.

Right click the RStudio app, and Run as administrator. Uncheck Blinking cursor per usual, and the blinking should stop.

Let me know if this works.

Darn it's back. I am just writing in Notepad++ for now, and pasting into RStudio. I am interested in learning about other things people try. Thanks in advance

I was just able to reproduce this issue. It looks like it occurs if you do a long-press of the mouse button while you have an active selection. I've filed the issue at https://github.com/rstudio/rstudio/issues/4895 and we'll try to get to the bottom of this.

Thanks for reporting!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.