Disable Ctrl+O shortcut mac

rstudio

#1

The Ctrl+O keyboard shortcut on mac is redundant, since we have Cmd+O to open files as well. This in itself isn't an issue. However, I often use the nano text editor in the terminal, which uses the same Ctrl+O shortcut to save the file being edited. Despite having removed Ctrl+O in the "manage shortcuts" menu, it persists. This obviously isn't a serious issue, but the inconsistency between Terminal.app and RStudio's terminal is mildly irritating

Anyone know of an easy workaround?


#2

Go to tools and modify shortcuts and then you can change Any key to anything you want


#3

I've tried removing it, setting it to something else but it hasn't had an effect. Does this suggest this is worth a bug report, or am I just being thick?