Disconnected from the server

shinyappsio

#1

Hi everyone,

I was trying to deploy a Shiny App to Shinyapp.io but I the issue with "Disconnected from the server".

One warning message I got was

2018-08-28T21:23:59.810769+00:00 shinyapps[410572]:   incomplete final line found on '/srv/connect/apps/check2/check2.rmd'

2018-08-28T21:23:59.811726+00:00 shinyapps[410572]: /opt/connect/ext/pandoc2/pandoc +RTS -K512m -RTS /tmp/Rtmp6ylcrE/check2.utf8.md --to html4 --from markdown+autolink_bare_uris+ascii_identifiers+tex_math_single_backslash --output /tmp/Rtmp6ylcrE/filef767a13d7.html --email-obfuscation none --standalone --section-divs --template /opt/R/3.5.0/lib/R/library/flexdashboard/rmarkdown/templates/flex_dashboard/resources/default.html --include-in-header /tmp/Rtmp6ylcrE/rmarkdown-strf77dbffd90.html --id-prefix section- --variable 'theme:simplex' --mathjax --variable 'mathjax-url:https://mathjax.rstudio.com/latest/MathJax.js?config=TeX-AMS-MML_HTMLorMML' --include-in-header /tmp/Rtmp6ylcrE/filef73db5251chtml --include-after-body /tmp/Rtmp6ylcrE/filef7442f38f4.html --highlight-style pygments --include-before-body /tmp/Rtmp6ylcrE/filef7724b386.html --include-after-body /tmp/Rtmp6ylcrE/filef7f818a.html

I've already set the advanced settings for Startup and Idle Timeouts. Please see the attached.

Not sure what to do next. The shinyapp does take a longer time for running.

Thank you!

Y


#2

That's really the only thing that looks remotely like an error in your log? I would've expected to see more. How about increasing your instance size? One way you can have your R process killed without seeing anything in the log, is if the memory limit is exceeded--the OS will terminate the process unceremoniously.


#3

Hi,

That’s the only thing from the log. I suspect it’s something related to the coding not to the Shinyapp.io.


#4

Hi,

That’s the only thing from the log. I suspect it’s something related to the coding not to the Shinyapp.io.

I already increased incidence size to 1GB.My biggest shape file is about 200MB and the process is creating simple mapping (interactive leaflet map).

I noticed it took very long to create the interactive leaflet map on my local machine. Does that have something to do with the disconnection?

Thank you so much for your reply!

Y


#5

If the leaflet map is being created before the application is responsive, then it is possible that shinyapps.io is seeing the application as not working and stopping it.

I would recommend taking the map creation out of the startup flow and see if that helps.


#6

Thanks!

Yes, I’ve tested without the map and it works. I’ve seen flexdashboard example with interactive leaflet maps and tested their source codes and all worked.

Y