Dissabling ssl certificate verification for deploy to Linux server

...Hi all,

I am trying to deploy a shiny app based on private packages to a Linux red-hat machine with a mini-cran like repository set up. I am trying to deploy to the server via rsconnect and while I am able to establish a connection and initiate the deploy it is not able to complete due to issues with curl.

I get both messages:
"Curl: (60) Peer's certificate issuer has been marked as not trusted by the user"
"Curl: (22) The requested URL returned error: 403 Forbidden"

The log is much longer and includes suggestions and pointers I have tried to follow, mostly to disable ssl verification.

I have tried the three suggestions:
set_config(config(ssl_verifypeer = FALSE))
options(RCurlOptions = list(ssl_verifypeer = FALSE))
options(rsconnect.check.certificate = FALSE)

and several variations thereof but the problem persists. Any suggestions on where to look next or alternative solutions would be greatly appreciated. I am relatively new to this area and there is alot of pressure to get this solved soon.

Best Regards,

I couldn’t help but notice that you are using one of RStudio’s pro products (your tags include rsconnect).

This also gives you access to access to RStudio's premium support ticket system at https://support.rstudio.com/hc/en-us/requests/new. Are you using Connect, by chance?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.