DLL ‘splines’ not found: maybe not installed for this architecture?

First post here - I've recently changed work laptop to a windows 10 machine with OneDrive auto saving everything. Having trouble loading tidymodels.

Error: package or namespace load failed for ‘tidymodels’ in library.dynam(lib, package, package.lib):
 DLL ‘splines’ not found: maybe not installed for this architecture?

Have tried a few forum posts that suggest trying to reinstall tidymodels package with dependencies but no joy:

install.packages("tidymodels", dependencies = TRUE)
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

trying URL 'https://cran.rstudio.com/bin/windows/contrib/4.0/tidymodels_0.1.3.zip'
Content type 'application/zip' length 55340 bytes (54 KB)
downloaded 54 KB

package ‘tidymodels’ successfully unpacked and MD5 sums checked

still get same error

Any ideas?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.