Dlookr Package won't install or load.

Helo all

I tried installing the package dlookr and then used library(dlookr) to load the package, but this is what I get:
R-CODE:

install.packages("dlookr")
Installing package into ‘C:/Users/theun/OneDrive/Documents/R/win-library/3.4’
(as ‘lib’ is unspecified)
Warning in install.packages :
dependency ‘RcmdrMisc’ is not available

There is a binary version available but the source version is later:
binary source needs_compilation
dlookr 0.3.9 0.3.11 FALSE

installing the source package ‘dlookr’

trying URL 'https://cran.rstudio.com/src/contrib/dlookr_0.3.11.tar.gz'
Content type 'application/x-gzip' length 4940189 bytes (4.7 MB)
downloaded 4.7 MB

ERROR: dependency 'RcmdrMisc' is not available for package 'dlookr'

  • removing 'C:/Users/theun/OneDrive/Documents/R/win-library/3.4/dlookr'
    Warning in install.packages :
    running command '"C:/PROGRA~1/R/R-34~1.1/bin/x64/R" CMD INSTALL -l "C:\Users\theun\OneDrive\Documents\R\win-library\3.4" C:\Users\theun\AppData\Local\Temp\RtmpK6F9MV/downloaded_packages/dlookr_0.3.11.tar.gz' had status 1
    Warning in install.packages :
    installation of package ‘dlookr’ had non-zero exit status

The downloaded source packages are in
‘C:\Users\theun\AppData\Local\Temp\RtmpK6F9MV\downloaded_packages’

library(dlookr)
Error in library(dlookr) : there is no package called ‘dlookr’

R-CODE END

How do I fix this? ANY help would be awesome, thanks!

You are missing this dependency, you need to install it first, but the problem is that RcmdrMisc requires R version >= 3.5.0 and apparently you are using 3.4 version, so you have to update R first.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.