Do NOT restore .RData into workspace on startup

When I log into Rstudio server, it usually takes a long time to load because RStudio server reloads my environment. I do NOT want to restore/reload data into my workspace on startup.

Changing my global & project options doesn't change Rstudio's behavior. "restore .RData into workspace on startup" is not the only global option that is ignored (Rstudio also restores the most recently open project on startup), it's just the only one that I really care about.

Here are my global options:

Since I'm not permitted to include this in my original post, I'll include it here.

Here are my project options:

Here is the version info:
image

Maybe this issue is already solved in the latest RStudio version (v2021.09.1+372). If not, then I think you should file an issue on the GitHub repository.