dplyr > package


I tried to submit my package in CRAN and there is a message below.
I follow the recommendation from CRAN's team to install R-devel version.
So I confirm the issue with dplyr
I call dplyr in some function by import(dplyr) ans in my rmarkdown library(dplyr)

I would like to know if someone I've an idea to solve this problem?

thanks in advance to your help !

Below message from the CRAN

Check: re-building of vignette outputs, Result: WARNING
  Error(s) in re-building vignettes:
  --- re-building 'mypackage.Rmd' using rmarkdown
  Attaching package: 'dplyr'
  The following objects are masked from 'package:stats':
       filter, lag
   The following objects are masked from 'package:base':
       intersect, setdiff, setequal, union

Hi, I reckon the problem, according to your first post, is on your vignette building. SO, the code inside the vignette may be the issue?

There are any issues with my code when I charge the package dplyr there is a message in the first post. The rmarkdown it's ok.
So I tried to post my package in CRAN and it's not possible to do it due to the library dplyr.
How I can solve it?

I tried to use conflicted package in my rmd file and I've put in description file (usethis::use_package("conflicted"))
start of the rmd script

conflict_prefer("filter", "dplyr")

After that, I used devtools::check(args = c('--no-manual','--as-cran'))
Below it's OK.

── R CMD check results ─────────────────────────────── mypackage ────
Duration: 58.2s
0 errors ✔ | 0 warnings ✔ | 0 notes ✔
R CMD check succeeded

I used conflict_scout()

6 conflicts:
* `filter`   : [dplyr]
* `intersect`: [dplyr]
* `lag`      : dplyr, stats
* `setdiff`  : [dplyr]
* `setequal` : [dplyr]
* `union`    : [dplyr]

And After that I used r-devel check

bash R-devel.sh CMD check --as-cran .../mypackage_0.0.0.1.tar.gz

the result is

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
  there is no package called ‘conflicted’

With this error the status is : 1 ERROR, 1 NOTE

To tell you the truth, I'm completely lost in solving the problem. I went to different websites without really finding a solution.
Can you help me?