Dramatic screen resolution issue - see screen snip


#1

Hi, I have recently obtained a nice new laptop with a 4k screen. Rstudio is one of my core apps. Sadly when I run Rstudio, it appears with a font which is so tiny no one could read it (see uploaded image of screen dump). I have tried to adjust some of the global settings, screen resolutions, but with no real improvements. Does anybody know how I can make this scale normally? I have some other apps with a display issue, but none as severe as with Rstudio. Many thanks in advance for any ideas. Cheers,
rwillia2001.

Here are my laptop specs:
Intel® Xeon® E3-1535M v6 Processor (8MB Cache, up to 4.20GHz
64GB RAM
Windows 10 Pro for Workstation (available for Xeon processors)
15.6" 4K (3840 x 2160) Anti-Glare IPS
Intel hd grapics P630
NVIDIA QUATRO M2200


New user and GUI text size
Fonts are too small with HiDPI display (4K) : ok for editor and console, but not for menu & tabs
#2

Hmm - sounds like the global settings you tried might be different than the Rstudio Global settings…perhaps try within Rstudio: Tools -> Global Options… -> Appearance. Then play with the font size? Maybe this is what you have already done, but if not its worth a try…


#3

considering your screen shot a littler closer and that you likely tried what I suggested this might be more relevant:

https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices

I am currently on a Mac so I couldn’t test it out.


#4

Cheers! For the editor and console font size 18 seems to work quite well (actually reading the options in the drop down box was impossible!). The right hand side env and files panels are still in tiny font land. I will have another fiddle.


#5

hmm - are your tabs and toolbar still in tiny font land as well? Maybe try Zoom in/Zoom out under the View menu as per

??


#6

Unfortunately, high DPI support is currently not great in RStudio (we plan to improve support greatly in the v1.2 release). You should be able to work around this by toggling the Zoom level in the Appearances pane, e.g.

On my high DPI Windows machine, setting the zoom level to 150% seems to fix things up. You might also try 200%.


#7

Cheers – I have got something usable working now, but moving to high DPI with Rstudio is not yet plug and play. Since it is one of my favourite apps I will be sticking with it.


#8

@kevinushey I’m curious - will this improved support also include support for cases where a high-DPI laptop has an external normal-DPI monitor connected for a dual-screen display? For example, sometimes using View(df) I will pop the df out into a new window and drag it to my external monitor to view side-by-side with my code, but the sizing of that window on the external monitor is humongous.


RStudio v1.2 has problem with DPI in high resolution monitor
#9

While I can’t make any promises, I am hopeful that we’ll be able to support this on Windows 10 and above with the next update.