Emacs key binding


#1

Hi,
I wonder if anyone has the same issue here, or this is because I didn’t set it up correctly.
I am using Rstudio 1.1.414 on windows 10. I have selected the emacs keybinding in the global options, but somehow the following two keyboard shortcuts are not working ( both are default under emacs),
Ctrl-w (kill a marked region)
Ctrl-y (yank)

thanks.


#2

I reply to my own question. It turns out this could be due to settings/versions related to emacs. I have to use ‘C-c C-w’ to kill a region.


#3

Thanks for the bug report! This isn’t intentional; I’ll file an issue and we’ll try to figure out what’s going on.


#4

I have the same issue, Ctrl-y still doesn't work for me, so is any Alt- F, E, C V... which opens up the manu bar. I was thinking it is worth it to use Emacs in R studio


#5

I love the fact that some softwares (and even some linux desktops) try to set emacs keybindings. Kudos to RStudio for that. Some people have also put autohotkey scripts or other config files out there to have emacs keybindings outside emacs. Unfortunately, I have never seen any of them work satisfactorily. My experience is that there are always many keys that don't work or conflict with something, giving, at best, an odd mixture of keybinding systems. Eventually, I gave up on the idea and do everything in emacs :smile: (including R).


#6

An option that might be worth exploring: exwm. I just started using it instead of openbox. It is possible to have emacs keybindings through it instead of local keybindings. This was not my reason to switch to it though and I haven't played with it a lot. But I thought that I would throw the idea out here, in case it is useful.

Edit: I actually just tested the keybindings it works great. So not only exwm provides a brilliant emacs windows manager, but it also solves the keybindings issues :slightly_smiling_face: