Empty and non-responding GUI on MacOS 10.15.6


Device: Mac Pro 7,1 (2019)
Processor: 3.2 GHz 16-Core Intel Xeon W
Graphics: AMD Radeon Pro W5700X 16 GB (x2)
OS Version: Mac OS X 10.15.6 (19G2021)
R version: 4.0.2
RStudio version: 1.3.1073

I installed R version 4.0.2 and then RStudio v1.3.1073 for the first time on a new computer.

R works fine but whenever I launch RStudio, the GUI loads but remains empty (see picture enclosed). I cannot access any of the functionalities of RStudio as the GUI is non-responsive.

I tried installing older versions of R and RStudio (including a version that works on another machine), but that did not solve the issue.

Launching RStudio generates the following Crash Report regardless of the version used:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x4] Symbol missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Symbol not found: _GEkillDevice
Referenced from: /Applications/RStudio.app/Contents/MacOS/rsession
Expected in: flat namespace in /Applications/RStudio.app/Contents/MacOS/rsession

Similar errors have been reported online, but they were all caused by a blocked connection. I have no antivirus or firewall installed on my machine, and RStudio has full privileges. I have also checked that R was properly installed and that all frameworks were at the right place, and I did not find any problem there. Restoring RStudio's desktop state did not help either.

I tried launching RStudio directly from the executable, but I get the following error on a loop:

GVA encoder info: AMD performance mode : 2
GVA encoder info: deleteSCDMetalContext : texture cache hits: 0, misses: 0
[1527:59907:0813/143752.790274:ERROR:gl_context_cgl.cc(136)] Error creating context.
[1527:59907:0813/143752.790314:ERROR:gles2_command_buffer_stub.cc(262)] ContextResult::kFatalFailure: Failed to create shared context for virtualization.

This error seems to be hardware related, but I am pretty puzzled as to how to address it.

Any help would be much appreciated!! Thank you.

1 Like

This is an obscure problem, traced to a type of virus software you are not using in this thread. The second error points to an issue with the default GPU / os integration settings (Tools | General | Advanced).

Is there anything in /home/roc/.rstudio-desktop/log/ that sheds more light?

1 Like

Thank you for your response. I checked the folder and it is unfortunately empty.

This thread reports an error similar to the one related to the GVA encoder. The error popped up with another software apparently because of a conflict between OpenGL and QtWebEngine. I found some evidence that RStudio uses QtWebEngine to render things onscreen (thread here). Someone also had the same issue on Ubuntu with different hardware (thread here). I have not found a way of changing the rendering engine on RStudio though.

1 Like

There is a option to adjust rendering in the menu tree global option tab. I don't know where it's stored in the desktop configuration to change manually. I'll see if I can get someone with more insight to check.

Thank you for your help!

Jonathan from the IDE team reports

This is usually the result of a corrupt R installation on the machine.
This is the issue tracking the problem: https://github.com/rstudio/rstudio/issues/5507

Thank you, I went through the GitHub thread.

Unless I misunderstood it the crash report that I get does not seem to relate to a failed connection. Furthermore, all of the versions of Rstudio that I installed (v.1.3.1073, v1.3.959, v1.2.5042, v1.1.463) had the same issue. My issue did not occur as the result of an update, it was the first installation on a new computer. Basically, Rstudio never ran on my machine.

I have reset the Rstudio desktop state but to no avail.

I will be following the GitHub thread. Do you recommend that I add my issue to it?

1 Like

Hi @moussz

I had a similar issue a week ago with an installation of R and RStudio (latest version both) in a new computer running Debian.

I haven’t been able to solve the problem but at least I got RStudio working (like a charm) using the Free Trial of the RStudio Pro version. You may try installing it to see if we can spot some light on the issue. I sincerely have no idea on the technical differences between these RStudio versions but I think we may get a clue if it also works in your case.


1 Like

Thank you for your input @juanvillada! I tried installing RStudio Pro but ran into the same issue.

I managed to get RStudio running by following this troubleshooting.

The issue did come from the Rendering Engine. RStudio is set to "Auto-Detect" by default (this is the recommended option), and I guess that the Rendering Engine that it automatically selected was "Desktop OpenGL". I do not know why this option is incompatible with my machine, but I have now set it to "Software". RStudio now launches without any issue.

Also, since the interface did not load correctly, I had to first start RStudio using the terminal and the command (for Mac):

export RSTUDIO_CHROMIUM_ARGUMENTS="--disable-gpu"

I do not know how this rendering affects the performance of RStudio, but time will tell. I also wonder is this should be considered as a bug.

Thanks everyone for your help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.