error after updating tidyverse - Error: package or namespace load failed for ‘tidyverse’ in loadNamespace

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): namespace ‘vctrs’ 0.3.7 is already loaded, but >= 0.3.8 is required

I'm assuming this error occurs when you tried to load the tidyverse package (We encourage folks to pose their questions with a reproducible example to help make questions as clear as they can be: FAQ: What's a reproducible example (`reprex`) and how do I create one?)

This error means you've tidyverse without updating the vctrs package. install.packages("vctrs") should fix the error.

Borrowing from this discussion, more generally, if you haven't updated packages in a while, you might want to try the "Update" button in the Packages tab of RStudio and consider updating other packages as well.

As I fix one issue, I get another one. So, I just upgraded r program, problem solved!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.