Error: * Application depends on package “glue” but it is not installed

shinyappsio
#1

I'm trying to deploy a Shiny app to shinyapps.io and I get the following error:

Preparing to deploy application...DONE
Uploading bundle for application: 305475...Error:

  • Application depends on package "glue" but it is not installed.
    Please resolve before continuing.
    Execution halted

I've tried putting library(glue) in my global.R file, but the same error persists.

The app runs smoothly locally. Any ideas how to troubleshoot?

0 Likes

#2

You generally have this error when a :package: is not found in current installed packages during deployment. Can you check you have glue installed in your R session ? If so, see where it is ?

You could even reinstall ggplot to update it, and see if it free things up

2 Likes

#3

Thanks @cderv. I checked my .libPaths() and verified that glue is present in both. I also reinstalled glue and ggplot2, but the same error persists.

> .libPaths()
[1] "C:/Users/rpauloo/Documents/R/win-library/3.5"
[2] "C:/Program Files/R/R-3.5.1/library"  

However, the version of glue in .libPaths()[1] is version 1.2.0 and the version of glue in .libPaths()[2] is 1.3.0. Perhaps I need to point my deployment towards the more up-to-date version of glue during deployment?

0 Likes

#4

Problem solved!

I simply had to reinstall ggplot2 and the issue resolved.

2 Likes

#5

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

0 Likes

closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes