Error at osmdata package

Hi all,

I need help as my code was working perfectly until I received the following error:

Error: package or namespace load failed for ‘osmdata’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘ellipsis’ 0.3.1 is already loaded, but >= 0.3.2 is required

I tried to reinstall both osmdata and ellipsis packages although did not work....

Many thanks for your help.

This message is asking you to update the ellipsis package, if you have tried to update the package but yet you keep getting the same error message, then most likely the package is not being updated successfully as you think. Can you post the complete output message you get when you try to install it?