Error compiling R on HP-UX 64 bits

I tried to install R on HP-UX 11.31 64 bits (I need R on 64bits not in 32bits). I downloaded the R source from CRAN-R. Before configure R, I also installed gcc (including gettext, libinconv, zlib, libunistring), downloaded from

I execute the ./configure command, to compile R but the following error appears:

configure:5837: checking for gcc
configure:5853: found /usr/local/bin/gcc
configure:5864: result: gcc
configure:6093: checking for C compiler version
configure:6102: gcc --version >&5
/usr/lib/hpux32/ Unable to find library ''.

In fact, is not in /usr/lib/hpux32 but in /usr/lib/hpux64. Any idea how to make the configure command to look in the hpux64 folder instead hpux32 folder?

One thing to try is to put a link in your SHLIB_PATH

Thanks. I've just saw that this info is defined on "configure" file. Do you know if there is any problem if I edit it?

I'm not a HP-UX user, but it sound fairly safe, assuming, always, you first make a back-up file of the original

Hi @technocrat... I tried to edit the "configure" file, but apparently because I already execute once "./configure", the change is not reflected. Is there any way to clean "cache"?


I don't want to lead you into the swamp. I'd suggest a fresh download and seeing if you can get some help on setting SHLIB_PATH in your .profile or .bash_profile equivalent on stackoverflow, where there are bound to be more HP-UX peeps.

Thanks! Now, a new error appears. I have installed G95 instead Fortran 77. When I execute "./configure" command, the following error appears:

checking for rl_callback_read_char in -lreadline... no
configure: error: --with-readline=yes (default) and headers/libs are not available

So, I tried to run the following command: "./configure --with-readline=no" but now, I have the following erro:

checking how to get verbose linking output from g95... configure: WARNING: compilation failed

checking for Fortran 77 libraries of g95...
checking how to get verbose linking output from gcc -std=gnu99... -v
checking for C libraries of gcc -std=gnu99... -L/usr/local/lib -L/usr/local/lib/gcc/ia64-hp-hpux11.31/4.2.3 -L/usr/ccs/lib -L/usr/local/lib/gcc/ia64-hp-hpux11.31/4.2.3/../../..
checking for dummy main to link with Fortran 77 libraries... none
checking for Fortran 77 name-mangling scheme... configure: error: in `/usr/install_r/R-3.4.3':
configure: error: cannot compile a simple Fortran program

any idea? Regards,

Well, as I feared, my 20+ years since dealing with HP-UX has put me deep into the Big Muddy. I'm afraid I have to consign you to the not-so-tender mercies of stack-overflow or a HP-UX SIG that might be out there.

I'm sure you have a compelling reason to do this on a speciality OS, but it's a lot easier on Ubuntu, especially if you have the option to install it as a virtual machine on your host.

As an alternative, consider EC2 instances of Ubuntu on AWS. It's something of its own Sisyphus learning curve, but you can set it up on web and ssh into it without having a VM on your HP-UX host. Unless, of course, Those Whose Lives as IT Professionals Would Be Bliss If It Were Not For Users, have shut you off from port 22.

As much as I'd love to be of some help, fakin' it 'til you make it at someone else's expense ain't the right thing to do. That said, if you need help puzzling out some more universal details, "I'm in town all week," said the comedian, and ping me @technocrat if I miss your question.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.